LightwaveRF Switch not working

  • December 18, 2015 at 22:11 #20638

    Hi All

    I have bought few LightwaveRF switches to replace existing switches and all are 1 gang. My electrician said it’s not going to work, because all of them are 2 Way which is not supported by LightwaveRF.

    Is any one got a solution, because I can’t return those. I have opened from original boxes.

    Is there are any 1 gang, 1 Way RF switches?

    I am new to this forum,



    December 19, 2015 at 03:13 #20639

    Might be time to get a new electrician perhaps?

    There are no 1 way switches as the same switch does both 1 way and 2 way.

    Same as for the standard switches.

    You have the switch wire…

    red + black (with sleeve) or…
    brown + blue (with sleeve)

    red/brown goes to L

    black/blue goes to o/p (arrow terminal)

    the remaining S terminal is for the slave, i.e. 2 way, which you just leave, i.e. no connection.

    developer of BMS Link ( A cloud based Home Automation platform for LightwaveRF, Z-Wave, RFXCOM.

    December 19, 2015 at 12:21 #20641

    Yes, tell your electrician to go back to college. This lack of expertise amongst those who are meant to have it is quite common. Many electricians seem to be limited to installing a lighting or power circuit, which is for most of the time all they are doing, but give them something a little different and you are stuck. Two years ago my bathroom and kitchen were refitted, all switches and sockets installed were LWRF, the electrician was quite flummoxed when the lights came on when the switch was off. I had to explain. Same problem arises with installing Evohome, it’s an electrician experienced with heating systems that is needed.

    December 31, 2015 at 10:32 #20741

    That’s exactly my experience too. The electrician I use and the plumber I used to use had no idea how to operate LightwaveRF and Evohome respectively, let alone install it! However their core expertise has been exemplary, so I can guide them through the bits I require them to do and perform the rest myself. Now I preach about having a concise product portfolio at work because it makes support easier for us and better quality for the customer. It would be wrong not to suggest the same for other professions too, and those that do specialise in smart-homes and HA are usually harder to find and can end up being more expensive.

    Having said that, opening to the page in the manual with the wiring diagram for a power switch or a dimmer, there should be no excuse for a seasoned electrician. Just don’t expect them to configure the dimming ranges, the Link, wireless switches or mood controllers.

    February 22, 2017 at 13:00 #23298

    Hi all

    Am having a similar problem, the plug is wired correctly and works if I click the switch on the plug however it’s the software which I believe is causing me a problem, when I select new device it says press button to start pairing (on the plug) and click ok on software except wether the plug is pressed or not the software pairs the device even with the plug off and doesn’t work at all!!
    Now this sounds like some messed up software not working correctly ?

    So that’s my issue the software is buggy as hell and I would love some help on how to fix this please

    Many thanks

    February 22, 2017 at 14:17 #23300

    The software is not buggy. (at least not in this instance)

    The LWRF plug is not designed to transmit any information back, it’s just a receiver. Hence the software cannot know if it’s successfully linked.

    You have to first put the plug into linking mode (press the button til the leds flash blue and amber)
    Then click on ok in the app. At this point the wifilink will broadcast an identifiable signal for the plug to “link” with.
    If the plug detects this signal it will flash blue to tell you (not the app) that it’s worked.

    If the plug doesn’t flash blue, it hasn’t worked, either because it can’t detect the signal (maybe the wifilink is too far away) or it’s already linked to the maximum number of controllers or maybe it’s broken.

    February 22, 2017 at 16:18 #23301

    I agree, this does not sound like a software bug at all. I have had LWFR switches throughout the house for over three years, apart from one location. Sounds as though the switch has not been paired correctly. If it is not pairing it may be worth trying a reset of the switch to wipe any pairings that might have been done and then try again. To reset set put the switch into pairing mode with the lights flashing, then hold down the button again, both if it is a light switch I believe, keep held down until it flashes a different colour, lift finger/fingers then press again. I think that is the sequence, it is in the “manual” though.

You must be logged in to reply to this topic.