Gen 2 released today – who is going to upgrade?

  • October 9, 2017 at 12:50 #24205

    lonebaggie wrote:
    Much too expensive , slowly replacing my lightwaverf kit with this

    Two way Zigbee. I am already running the hub and sensors . Kit runs in Domoticz, Smartthngs Home assistant and Homey

    Light switches are two wire no neutral. The native app is miles better than Lightwaverf even if some of it, is still Chinese !

    Sorry version 2 is too little too late

    What switches would you recommend?

    I have just order one these

    to see if works correctly . Already running the Hub and sensors which work fine . Build quality good on hub and sensors . Will let you know how I get on

    October 10, 2017 at 08:32 #24214

    I’ve got a UPS tracking number now.. hopefully my gen2 bits will arrive tomorrow..

    October 10, 2017 at 10:24 #24215

    Existing User – received the Link Plus 9th Oct 2017


    1) Until the software is made better, and bugs sorted, it is highly likely you will return the Gen 2 hub to your supplier, unless you like being a beta tester!

    2) Looks like it is still early days for existing users, but might be OK for new users buying Gen 2 sockets and switches only.

    3) Suggest – Keeping your existing (Gen1) setup, and start fresh as a New User with (Gen 2) Link Plus hub! (Hopefully, one can revert back to Gen 1 system).

    4) The Gen 2 App (iOS) has only 10 icons for pairing – Socket 2.Gen (L42), Dimmer 2.Gen (L21/L22/L24), Socket 1. Gen (One Way), Dimmer 1.Gen (Oneway), Energy Monitor (LW600), Boiler Switch (LW920), Thermostat (LW921), TRV (LW922), Magnetic Trigger (LW931)

    Relays not listed?

    5) LWRF iOS app – currently has no ‘Events’, Timers’ or ‘Heating’ etc – this app is of no use for existing users.

    6) Currently unable to pair LWRF TRV or Thermostat to the new LWRF app, but managed to paired some switches and sockets.

    7) There are comments about using a Apple TV Gen 4 or a iPad (that stays in the house) as a hub?

    Fun times ahead.

    October 10, 2017 at 10:28 #24216

    Got my Lighting & Power Kit. I think it’s going to stay in the box until the app is sorted. It has had 4 reviews (when i last checked) on the AppStore of 1 star, and sounds rubbish. I have quite a lot of Gen 1, and was hoping that everything could co-exist. Maybe one day it will, but I don’t think soon. Its hard to understand what the motive is to release such poor software (one hopes the hardware is OK if very expensive), which pays no attention to Gen 1 integration and looks like it is far from ready. Maybe they wanted to catch the hype of the new iPhone release? The whole thing is half-baked.

    October 10, 2017 at 10:37 #24217

    Relays not listed?

    In the existing app, relays are controlled as an “on/off” device which has a plug socket icon – there is no ‘relay’ option

    October 10, 2017 at 13:33 #24219

    re having to have a new app to support Gen 2 (rather than just supporting Gen2 in the existing app), they tweeted:

    “This was not technically possible as this is a radically new architecture which requires new software to accommodate the new hardware.”

    So fair enough, if it was easier to re-write the application from scratch then so be it, but maybe they should have added gen1 link support to the new app rather than now maintaining two applications..

    October 10, 2017 at 16:27 #24220

    Gen 2 Technical Reply from LightwaveRF as at 10th October 2017

    Hi Martin,

    Thanks for your query.

    The Gen2 app will have automation feature added (Timers) in the next couple of weeks .

    Instructions to pair existing (Gen 1) LWRF TRV and Thermostat to (Gen 2) Link Plus :-

    Please reset the Link, log out from the app and log back in and now try to add your heating devices :

    1. Unplug the Link Plus from the Mains
    2. Hold your finger on the link button (chain button) Do not let go
    3. Plug the power back to the unit while holding your finger on the link button still
    4. Wait for the link to flash yellow , now let go and tap the link buttons once quick
    5. After a factory reset you would need to clear the device memories too (similar to gen 1 method) before pairing.

    We will have instruction added to the new FAQ section of the app.
    Lightwave Technical Support

    Hope this helps!

    October 11, 2017 at 12:43 #24223

    Well… Lightwave don’t seem to know the difference between an invoice vs shipping address so have mis-shipped it… might get redirected tomorrow.. good farce so far…

    My plan is to try and run both old and new link in parallel somehow until the old one can be dropped
    Use old link for the timers and events for the moment
    Use the new link for control via the phone
    something like that!
    Will document what happens as i make progress….

    October 11, 2017 at 14:52 #24224

    I thought I would add an update to an earlier post regarding my difficulties with the new Gen2 kit.

    So in part this is to commend the Lightwaverf support team in their efforts to resolve what must be a significant number of issues being generated from early Gen2 adopters/customers.

    I now have a working limited functional setup combining a some simple Gen1 devices and a Gen2 power socket and lightswitch. The devices now operate in simple on/off mode from the Lightwarerf iOS app and IHome. It did take a full wipe of the link unit and the devices needed re-adding, but we got there. Time will tell how stable things are.

    However, I would still recommend any new user, or someone with limited patience in new kit, to WAIT before they purchase as the APP needs a lot more work and key features from the Gen1 app to be added back in which they say is promised in the coming weeks.

    October 11, 2017 at 16:28 #24226

    I see the iOS app is updated today
    * bug on linking devices after linking Link Plus
    * UI improvements
    * support for relays..

    October 12, 2017 at 10:20 #24227

    well it’s arrived – with security tags broken – have emailed LWRF to ask if it should be received in that state..

    You must be logged in to view attached files.
    October 13, 2017 at 07:29 #24236

    Blimey… where do i begin!?!?!

    TL:DR Do not buy Gen2 yet – it is buggy as hell, missing all the required features and only a sadist would put up with it.

    Let’s start with the Gen2 App (V1.0.5 on iOS, Link Plus v1.4.0)

    2 screenshots attached – this is the app in its entirety:
    1) A ‘favourites’ page with all the devices.
    2) A ‘settings’ page with no settings

    There are no Rooms
    There are no Moods
    There are no Timers
    There are no Events
    There are no Zones
    There is no grouping of any kind..

    To start, i thought i will run old link and new link in parallel – seems a good idea as Gen2 is missing significant functionality.

    I added all my Gen1 devices to the new link – some linked OK, others took multiple attempts to get them to link. Some worked fine for a while then refused to work after a while – basically the Gen1 support on the new link is incredibly buggy at present

    I then tried to add the Gen2 double socket – this refused to link to start with, took multiple attempts before it linked, not knowing what i was doing i assumed you had to link each side of the socket seperatley (on first link only one switch showed up), so tried the button on the other side to link – wouldn’t work, deleted the socket, reset the socket, tried again, multiple attempts, then it shows up as two devices in the app the next time it linked successfully – now i can control both sides… I have no idea why linking the device was such a struggle, half wondering if it is sensitive to the name you call it, or maybe just depends which way the wind is blowing.

    Some further notes:
    – There is no Alexa support currently for Gen2 link
    – It appears that Gen2 devices cannot receive on the old 433MHz frequency, so Mood switches, Remote controls, PIRs etc from Gen1 are all redundant
    – The web portal ( cannot be used for Gen2 – the link does not show up (only my old link)
    + If you have more than one iOS device, the configuration synchronises between the new app on both
    + When you turn a Gen2 socket on/off, the state updates instantly in the app


    You must be logged in to view attached files.
    October 13, 2017 at 07:31 #24239

    A couple of screenshots showing device selection for linking, and also if you long-press on a device you get to a screen where you can set brightness, control device and lock device..

    You must be logged in to view attached files.
    October 13, 2017 at 07:32 #24243

    Here is how it looks in Apple Home Kit with the multiple Gen1 and 1xGen2 socket added – just the Gen2 stuff will show up (as expected)

    You must be logged in to view attached files.
    October 13, 2017 at 12:18 #24249

    All useful info thanks, will be setting up my gen 2 at the weekend.

You must be logged in to reply to this topic.